2014 Silverado window/door latch issue

Asked by Dec 24, 2017 at 10:58 PM

Question type: Maintenance & Repair

ok guys I have a 2014 Z71 LT the door ajar
light came on for drivers rear door I took it
apart cleaned door latch (contact
cleaner/dielectric grease lithium grease)
put it all back together light went of but still
have no control to dome light when door is
opened and now the window on same
door will not work and also passenger front
window will not work I'm sure this is an
electrical/switch/relay issue can anyone
point me at a starting point dealer says it's
needs a door latch and a new wiring
harness in that door which I might would
bite on but they didn't take it apart I'm
assuming they diagnosed by computer?
But now with the new issues I'm unsure
any help would be greatly appreciated
since truck is 4000 miles out of warranty
and dealer wants 900 to fix just dome/latch
issues

8 Answers

10,190

check the wire harness that goes through the body to the door it will be a black accordian boot.pull the boot back and look for any troubled wires.

1 people found this helpful.

Thanks I'll check that later.does all the power run thru the drivers foot switch to all windows? Just asking because it's the drivers rear door with latch and window issue and then the passenger front door with just window issue.

10

our chevy truck just hit 40,000 miles and the same thing is happening on the dash board the drivers side rear door shows open and dome light won't go off even when the door is closed firmly

1 people found this helpful.
10,190

sounds like a lock actuator issue.

10

What was the out come of this? My 2014 just stared doing the same thing. Door says it's open and rear window doesn't work. Sounds like this should have been a recall.

1 people found this helpful.
10

My 2014 is doing the very same thing. Any answer to the problem yet?

1 people found this helpful.

Does anyone have an solution for this. I just tore the door apart and changed the for the latch. No luck.

I have a 2014 Silverado as well with the same issue. Checked all the fuses, but no luck....still searching for an answer.

Your Answer:

Maintenance & Repair Experts

  • #1
    dandyoun
    Reputation
    108,300
  • #2
    tennisshoes
    Reputation
    99,840
  • #3
    tenspeed
    Reputation
    85,820
View All

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use. Content will be removed if CarGurus becomes aware that it violates our policies.