2004 dodge ram 1500

Asked by Oct 29, 2017 at 12:45 PM

Question type: Maintenance & Repair

My truck won't start or idle without my
foot on the accelerator. At stoplights, I'm
forced to keep one foot on the accelerator
and one on the brake. Above 1500 rpm, it
runs normal and strong as ever. This
motor is a 5.7 hemi. It has never seen dirty
oil, always had a clean air filter, never been
hot, and has been ran gently. When I slow
down or come to a stop, the red lightning
bolt comes on briefly. I have done a spark
plug change (champion copper), air filter
change, new map sensor, new camshaft
positioning sensor, new crankshaft
positioning sensor, and cleaned the
throddle body. None of this changed
anything. Bad gas is a possibility as this
started with fueling at a place that I later
learned was known for having bad gas. I
did additives and I'm sure the gas was
burned out before replacing sensors. It
acts like a carburated motor with a terrible
vacuum leak. I have checked the only few
vacuum leak locations that I could find
(brake booster, map sensor, and egr). Any
advise would be greatly appreciated!

No answers yet

Your Answer

Shortcuts

Maintenance & Repair Experts

  • #1
    Tom Demyan
    Reputation
    184,690
  • #2
    dandyoun
    Reputation
    96,900
  • #3
    tennisshoes
    Reputation
    81,620
View All

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.