A/C

Asked by Sep 26, 2017 at 02:28 PM

Question type: Maintenance & Repair

The a/C in my 1997 Tahoe cut off in the
front vents but the rear control works fine no
air at all will come out cool or hot has
anyone had this problem and could tell me
what's wrong

8 Answers

2,790

1. Fuse or relay blown? 2. Blower motor or resistor bad? In front. 3. Evaporator tube clear? In front. 4. Heater actuator door working? (Do you hear plastic grinding in dash)? 5. Cabin air filter full? (If equipped)

1 of 1 people found this helpful.

Before it cut off completely the a/C would run constantly no matter what speed I had it on would that narrow down the possible problems

2,790

AC or blower? Blower without AC button on? Running all the time? Could you cut it off with the switch? Different speeds could you dial? I would start at the relay. I wonder if it was stuck on and then burned out? You also could have blown a fuse if it didn't cut off, circuit got hot. Rule those 2 out then go to blower motor and resistor.

2,790

I have also read a lot about those switches in those GM trucks going bad. The whole circuit board which is attached to the knobs.

Yes blower without the AC button on would not cut off, now no blower at all in front and I couldn't switch the speed at first it would just be on high the whole time

But thanks I will check it out

2,790

I would strongly suspect the blower resistor based on you only having one speed. This is a Common symptom of a bad blower motor resistor

1 of 1 people found this helpful.
2,790

Many YouTube videos how to test resistor and blower motor

Your Answer

Shortcuts

Maintenance & Repair Experts

  • #1
    Tom Demyan
    Reputation
    181,830
  • #2
    dandyoun
    Reputation
    96,050
  • #3
    tennisshoes
    Reputation
    79,710
View All

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.