I have a brand new alternator in 2011 jeep liberty and good battery. Alternator still not alternating current to battery?? replaced alternator and battery twice all connections look good. any ideas??

Asked by Aug 26, 2017 at 02:51 PM

Question type: Maintenance & Repair

4 Answers

3,200

All your grounds good? Body of alternator, engine, car body? All connections tight? No rust or corrosion? Have you done a voltage drop test on wires? Not just resistance but voltage drop. Could have gotten a bad alternator? PCM bad? Newer cars the computer runs the alternator.

1 of 1 people found this helpful.
104,415

Did you use the preset saver tool before removing the battery? If not then you will need to go to the dealer and have the system reflashed before the charging system will even turn on, you may also notice some of your other accessories will not work. Runs a hundred bucks in my area.

2 of 2 people found this helpful.
Best Answer Mark helpful

all connections are good . i think i need to go to a dealership to have a diagnostic run. its acting weird when i rev the engine pas 300 rpm it will start climbing on its own and i have to manually shut vehicle off or it will accelerate to its max...

104,415

Thanks for the points. If you engine speeds are acting like that then yes you need to have the systems checked, hopefully you don't have a bad processor.

Your Answer

Shortcuts

Maintenance & Repair Experts

  • #1
    Tom Demyan
    Reputation
    184,860
  • #2
    dandyoun
    Reputation
    96,910
  • #3
    tennisshoes
    Reputation
    81,670
View All

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.