96 Chevy

Asked by May 30, 2017 at 10:52 AM

Question type: Maintenance & Repair

Ok so I brought this truck about a year ago
for a good price, I knew I would have some
problems out of. It wouldn't go past 30
unless you put it in 2nd drive, but that
would run the rpms up & felt like it was
putting pressure on the engine. The guy
told me the torque converter was bad, but
by the time I had time to get it changed the
engines rocker arms when bad. I found a
deal on a engine & transmission so I went
ahead & got them bothed switched out cuz
for one the previous owner had the wrong
transmission in. Afterwards it drove fine for
about a week then went back doing the
same old thing, not going past 30 unless it
was in 2nd drive. I cut the converters off,
changed the oxygen sensors (all but one),
deleted the egr, changed the tps and the
connector to it, & I cleaned the throttle
body. The IAC is covered in carbon, I tried
to wipe some of it all, I want to use sensor
cleaner but I don't think that's the problem.
There is no check engine light but I did
check it & the only things that came up
was the EGR needing to be cleaned or
changed & the oxygen sensor I haven't
changed yet. I don't know what the
problem could be anymore, it's not as bad
as it use to be. The rpms still run high but it
doesn't feel like it's putting a lot of
pressure on the engine anymore.

No answers yet

Your Answer

Shortcuts

Maintenance & Repair Experts

  • #1
    Tom Demyan
    Reputation
    177,690
  • #2
    dandyoun
    Reputation
    94,460
  • #3
    tennisshoes
    Reputation
    77,220
View All

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.