C1500 idles good til warm up then dies sputtering and missing

Asked by Feb 04, 2017 at 10:05 PM

Question type: Maintenance & Repair

3 Answers

20,995

Start with basics, like tune up items, check or replace, Spark plugs & wires, cap & rotor, look/listen for vacuum leaks. Look for bad fuses, bad electrical connections. Shorts. Dirty or bad sensors, Throttle body or IAC or MAF/MAP dirty or bad. Throttle body base gasket. ect

Best Answer Mark helpful

So far I've changed. Plugs wires cap rotor coil, upper and lower intake gaskets, spider assembly,upper plenum,fuel pressure regulator, and tons of sensors(cam,crank,knock,ect,iac,tps,maf,map,iat,egr ). Fuel pressure is good, leak down good. At this point I'm thinking timing chain? Codes from the diagnostic(just done cause no check engine light shows) were cam and crank out of range, and cam crank correlation problem.

20,995

And timing/cam gears may be worn and if full kit is purchased it will have both. Also check for if they were loose before removing them or if bolts are not torqued down you may need new bolts too cause of stretched threads if it was loose.

Your Answer

Shortcuts

Maintenance & Repair Experts

  • #1
    Tom Demyan
    Reputation
    184,870
  • #2
    dandyoun
    Reputation
    96,910
  • #3
    tennisshoes
    Reputation
    81,670
View All

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.