Electrical Problem

Asked by Rick Nov 07, 2019 at 09:17 AM

Question type: Maintenance & Repair

I have a 1977 280z that has an electrical problem.  Here is what is going on.  I
open the door and the interior light turns on.  When I turn the key to ACC. I can
turn on the radio and antenna can be raised and lowered.  When I turn the key
to ON all the gauges work.  But when I turn on anything that draws more
amps, like the A/C fan or the head lights everything goes dark - no power even
the interior light goes off.  Turning the key to OFF and waiting about 45
seconds the interior light comes back on and the electrical system seems to
reset.  Oh if I turn the key to start nothing happens.  Any suggestions is
appreciated.

2 Answers

290,475

Weak battery or corroded battery connections.

1 people found this helpful.

Thank you F_O_R! My mechanic installed a new battery recently but failed to tighten two bolts on the positive terminal. Not the bolt that connects main cable to the battery post but the bolts that connect red wires that come off the terminal.

Your Answer:

Maintenance & Repair Experts

  • #1
    G A Arne
    Reputation
    171,980
  • #2
    F_O_R
    Reputation
    154,760
  • #3
    dandyoun
    Reputation
    139,330
View All

Find great deals from top-rated dealers

Search

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use. Content will be removed if CarGurus becomes aware that it violates our policies.