my 04 blazer defrost quit working. Does not appear to be the fuses. Please help

Asked by pupsrock Sep 07, 2012 at 07:27 AM about the Chevrolet S-10 Blazer

Question type: Maintenance & Repair

My 04 blazer defroster quit working.  Does not appear to be fuse-related.  Please help.

1 Answer

13,735

Check the connections at the rear hatch glass, the tab my have broken off. I'm assuming you are talking about the rear defroster?

Your Answer:

Chevrolet S-10 Blazer Experts

  • #1
    Cody Doud
    Reputation
    1,050
  • #2
    emtfirefighter77
    Reputation
    750
  • #3
    Markfisler
    Reputation
    540
View All

Find great deals from top-rated dealers

Search

Related Models For Sale

Used Chevrolet S-10
6 listings
Used Chevrolet Blazer
4 Great Deals out of 1,194 listings starting at $4,790
Used GMC Jimmy
5 listings
Used Chevrolet Trailblazer
27 listings starting at $2,950
Used Chevrolet Silverado 1500
115 Great Deals out of 10,340 listings starting at $3,655
Used Chevrolet Colorado
32 Great Deals out of 1,936 listings starting at $3,948
Used Jeep Cherokee
68 Great Deals out of 4,970 listings starting at $7,988
Used Ford F-150
194 Great Deals out of 12,440 listings starting at $2,197
Used Ford Bronco
1 listing
Used GMC Sonoma
7 listings
Used Chevrolet Tahoe
11 Great Deals out of 717 listings starting at $6,871
Used Chevrolet Impala
19 Great Deals out of 908 listings starting at $2,495

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use. Content will be removed if CarGurus becomes aware that it violates our policies.