not getting any fire

Asked by Apr 07, 2018 at 02:03 PM about the 2000 Chevrolet Blazer

Question type: Maintenance & Repair

I have replaced the coil pack, the distributor cab
the rotor button,module and still not getting fire
please help

1 Answer

990

Battery has a full charge and connections all good? Did you check primary voltage to ignition coil, pink wire, use a test light with key on, to check for voltage? Anything? I believe that circuit to be fuse protected. Does the rotor turn when you crank it?

Your Answer

Chevrolet Blazer Experts

  • #1
    Andrew Olsen
    Reputation
    2,260
  • #2
    yetilikesbeer
    Reputation
    1,550
  • #3
    Rowefast
    Reputation
    1,150
View All

Related Models For Sale

Used Chevrolet Tahoe
8 Great Deals out of 883 listings starting at $6,299
Used Chevrolet S-10
7 listings starting at $5,995
Used GMC Jimmy
16 listings
Used Chevrolet Silverado 1500
170 Great Deals out of 11,729 listings starting at $3,995
Used Ford F-150
478 Great Deals out of 10,813 listings starting at $2,995
Used Chevrolet Camaro
1,128 listings starting at $5,900
Used Jeep Grand Cherokee
151 Great Deals out of 4,551 listings starting at $1,800
Used GMC Yukon
12 Great Deals out of 1,068 listings starting at $3,800
Used Ford Explorer
33 Great Deals out of 1,619 listings starting at $2,900

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.