replaced batery and air does not come out the vents

25

Asked by wayne3046 Jun 24, 2008 at 11:09 PM about the 2004 Chevrolet Trailblazer

Question type: Maintenance & Repair

i replaced the battery and the ac air does not come out the vents

32 Answers

665

when loss of power to hvac unit sometime the hvac actuators need to be recalibrated. possibly try to remove the hvac control fuse under the driver rear middle seat for a minute and reinstall, turn key on and do not touch any hvac module buttons for another minute to allow actuator to recalibrate then recheck to see if repaired. if that does not fix it you will need to take it to a gm dealer to get it recalibrated with the tech 2 scan tool.

55 people found this helpful.
770

had battery replaced same issue removed HVAC fuse # 39 under rear seat waited 1 minute then replaced fuse Turn on ignition do not start engine. Wait 2 minutes then start this will recalibrate the actuators I got this from one of the web sites it worked just fine. All vents work correctly now.

73 people found this helpful.
390

I tried the all the above and still it did not work

39 people found this helpful.
480

Never heard of a driver rear middle seat.....??????

21 people found this helpful.
480

Cant even get under the rear seat. Where is the fuse?

27 people found this helpful.
420

Did exactly what was suggested by Daniel and ageary63 below for my 2004 Chevy Trailblazer. Removed the fuses (#36 and #39)and then re-inserted them after waiting about a minute. After re-insertion, turned ignition but did NOT start the engine. Heard the calibration take place behind the A/C controller for about a minute. Once it was quieted, started the ignition and the A/C was working perfectly again!! This fix probably saved me over $400.00 in unnecessary mechanic repairs. This all started because I had disconnected the batter in order to tighten the battery cable connections which caused my battery to drain regularly. God bless all of you with your help and good advice!

38 people found this helpful.
70

Cayenne_41435353 I took a look under my rear seat just yesterday because my radio stopped working pulled out some of the fuses tested them then I put them back now my radio works and climate control stopped working???

7 people found this helpful.
420

Would not know how to help as I am not a mechanic nor a car specialist. I simply followed the advice of previous writers regarding A/C. However, try You Tube and put in precisely the problem (e.g., "climate control not working in Chevy XXX") and Im certain you will find some do-it-yourself videos that could fix the problem. Sorry that I cannot help you directly but try You Tube.

4 people found this helpful.
250

https://youtu.be/xazoup8tUQM This is the video for the steps above. Trying these steps now. My 2006 trailblazer will not blow out of the bottom vents after replacing the battery.

14 people found this helpful.
250

https://youtube.com/xazoup8tUQM

11 people found this helpful.
70

I had to get more creative to get my controller to reset. I had already had a problem with the driver side blowing hot all the time while the passenger side blew cool. This was solved by changing the left temp actuator door. When I changed the door I noticed the new door was in the neutral (middle) position compared to the right door which was all the way open. When I reconnected the battery the AC controller recalibrated itself and everything worked fine. Later I replaced the car's (05 Trailblazer) battery and the top vents quit working. According to the schematics I had, this was due to the mode control door not working right. The air would come out of the top vents when I started the car, but it would start clicking then the top vents would close and all the air would come out the floor vents. I tried resetting it like it says to in SB 07-01-39-007A by pulling HVAC1 fuse for 5 minutes, putting it back in then turning ignition on for 90 seconds. It would not reset. When I turned the car back on it worked for a few seconds, started clicking, then started coming out the floor vents only. I thought maybe the controller couldn't calibrate unless the door started out in the neutral position. I counted the clicks until the door stopped moving (49). I turned it off, turned it back on again, waited until it started clicking and then pulled the fuse when it got to 25 clicks. Waited 5 minutes. Turned car to on for 90 seconds. Started car and everything worked. Not sure if this will work for everyone. Hope it helps some of you. GM knows they made a bad system. They just don't care enough to fix it.

7 people found this helpful.
40

I had tried EVERYTHING and finally the only resolution was for a Chevy Service dealer to go ahead and replace the actuators and a surprising cost of just over $500 ( previous was braced for a much higher estimate )

4 people found this helpful.
200

Help..replaced battery and ac blows out all vents even back but wont blow out of front vents..any ideas

19 people found this helpful.
200

Waiting on an answer

1 people found this helpful.
120

Guru read the forum bro

6 people found this helpful.
50

Thanks to all for the answers to this pulling the fuses and and resetting as stated by cayenne. I have had to do this multiple times the first time costing around $500 at the shop before I found this. It has worked every time for me, just had alt replaced and had to do it again.

5 people found this helpful.
80

2006 GMC Envoy upper AC vents not blowing air. Only the lower vents and the windshield blower working. Tried re-calibrating by pulling the 39 HVAC fuse, waited 1 minute, replaced the fuse, turned the switch on but not starting the vehicle, waited a few minutes,could heard the vehicle re-calibrating, started the vehicle, SAME PROBLEM. repeated procedure but pulled the HVAC 36 fuse, SAME PROBLEM; repeated the same procedure while pulling both the HVAC 39 and 36 fuse, SAME PROBLEM, started vehicle turned on upper and lower vents while vehicle was running, pulled HVAC #36 fuse, upper vents started blowing along with the lower vents, reinserted 36 fuse, vents kept blowing, turned on AC, BOOM!!! problem solved! Vehicles are sometimes sensitive and you may have to explore different angles. Thanks for everyone's advice!!!

8 people found this helpful.
20

I tried this Walter but my vents didn’t start blowing until I reinserted 36 fuse. But they started working normally, for now. It will be interesting to see if it holds calibration.

2 people found this helpful.
30

Can you post a picture of the fuse so I know what one to pull

3 people found this helpful.
20

John - I noticed after turning off my 2006 GMC Envoy Denali for 30 seconds and turning it back on, the calibration was gone and I was back to no upper vents. I'm still playing with it to try and figure out how to get this to stick.

1 people found this helpful.
10

Dorman sells a controller that has a built in calibration mode. I bought one, had to take one back because the temp sensor kept saying it was 30 degrees out when it was 96. They gave me another one. This one is better, It says it is 40 when the outside temp is 80. At least it allows the AC to come on. If I recalibrate it, it reads the correct temp. Called Dorman and they said to bring it back and they will replace it. Don't think I will. Tired of pulling my dash apart.

1 people found this helpful.
10

I’m a little confused . So I pull the fuses while the truck is running or the on position ?

1 people found this helpful.
20

@Joes20322 This is what I did, and it works, but so far for me only temporarily. Could be doing it like this is why it doesn't keep the settings. I'll reply back once I have mine fixed with exactly what I did.

1 people found this helpful.
10

I have an 04 Envoy SLT and like most of you, air only comes out of the 2 defrosts modes which is what I learned as the default modes. I don't know why it's doing that but I'm going to safely assume based on everyone's problem, that it's because I change my battery. I did try something that nobody else here has tried though which was to try and turn the knob that inserts into the actuator to see if all the vents would open up as I turn the knob. Strangely, it stops turning once it reaches the second default mode and doesn't wanna turn anymore so I thought that it was the mode door itself that's getting stuck to that point but when I tried pulling out fuse #36 while the system was on, it did blow out of the top vents only but when I put the fuse back in, it goes back into default mode of only the defrost modes. What I'm going to try and do is pull #36 fuse while the system is running so the air comes out of the center and then try turning that knob to see if I can cycle all of the models manually. This definitely seems to be an electrical issue. I did replace the mode door actuator and recalibrated it and nothing was resolved. I also saw a video that shows that if the actuator isn't lined up on the lines engraved, then it's out of its range and needs to go back in and the video shows how you can do that. On another note, I might have broken my new actuator because when I tried getting that annoying clip out, the whole turning mechanism came out as well but I aligned it back within the lines when I put it back in. I also checked the movement of my old actuator and it actually turns all the way when it's not mounted so I also have some figuring out to do. I will post an update once I have one.

30

Disconnected my battery long enough to replace the clutch fan on my 2006 Chevy Trailblazer. Hooked it back up, same problem, no front vents only floor and defroster. Pulled #36, put it back in and the vents work. Shut the car off and it went back to floor vents and defrost. Pulled #36 again, front vents worked. Shut the car off and when I came back out to leave again now NOTHING works. No air from ANY VENTS. Help

3 people found this helpful.
70

Hey guys I have a TB and been through that problem where the fuse removal did not work. What I do with 100% success every single time is: with key on move vent position to your face on controls and turn the blower off or to 0. Take the key out, unplug the positive terminal then reconnect. Get into your car and turn the key to the on position,( but do not start it). Let it sit like this for at least 2 mins. You will hear the actuators recalibrating themselves. After 2 minutes turn the key to off position then start the car and it should be working out of the correct vents. If you need to unplug your battery in the future, make sure to turn the vent to blowing at your face and to the off position for fan speed. When reinstalling battery wires follow these steps again to recalibrate the actuator.

7 people found this helpful.
10

TB07guru I'm gonna try that later. Thanks for the headsup.

I have an 08 GMC Envoy I took the number 36 fuse off and the vent started working but soon as I move it it they stay doesn't keep the calibration

10

I tried TB07guru's solution and sadly, it didn't work. I made a video of my issue and demonstrated what I mentioned two comments ago with the mode door actuator knob. https://youtu.be/Ap-vOTemAcA

1 people found this helpful.
10

After doing some more researching, I found out that there's a defrost actuator as well which is in the screenshot uploaded. I'll also be pasting a link from a tech that replaced his and the procedure he went thru to replace it. There's a strong possibility based on what the majority of us are experiencing, that it's not the mode door actuator that's bad, it might be the defrost actuator which is more of a pain in the ass to access but I was recently laid off from my job due to an injury so I have plenty of free time on my hands now so I'll be picking up my tools from my job soon and will be working on accessing that defrost actuator. https://gmtnation.com/forums/threads/2002-envoy- mode-door-actuator-replacement.2744/

So i have a 2009 Saab 9-7x Aero, the twin of the TBSS. I had disconnected my battery to fix a ground issue and when I reconnected I did not know about the calibration procedure. The AC went straight to footwell vents and did not change back. I freaked out and then i found out about the fuse pull to calibrate, I went ahead and did that, but again I didnt get the full instructions and as soon as I felt it blow out of the top vents I turned everything off happy thinking it's fixed. The following morning I found out it didnt work and it stuck to footwell vents. I have pulled the fuse and did the calibration again about a dozen times by now, in all sorts of varying attempts including trying to pull the fuse when the actuator is half way, disconnecting the battery, pulling different combinations of fuses and nothing seems to work. Like one of the answers above had mentioned, I get about 5 to 10 seconds of top vent flow upon starting my truck but then it switches to foot/defrost and stays there no matter what I do. HELP PLEASE, IM LOSING SLEEP OVER THIS

Hello Everyone I am new to the forum and this is my first time to write such answers. I had problem in my chevy TB 2007 LT 4.2. No air from passengers side and rear vents in stand by engine was on and in running it was blowing hot air might be from engine. I tried all the solutions posted in this forum but it didn't work. Finally, I went to workshop he said may be problem in blend door actuators and he is not sure to make solution for the said problem. Then I left from that workshop and moved to another workshop. I told the problem facing with my Ac and just hold the auto button for three seconds and it automatically started blowing cold air from the passengers side and rear (previously no air and while running my chevy blowing hot air). I made conclusion from this incident do not go for worshop just try to solve by following above solution mentioned in this forum for few days.

Your Answer:

Trailblazer

Looking for a Used Trailblazer in your area?

CarGurus has 24 nationwide Trailblazer listings starting at $5,995.

Postal Code:

Chevrolet Trailblazer Experts

  • #1
    FJ4072
    Reputation
    3,100
  • #2
    G A Arne
    Reputation
    1,990
  • #3
    bigdogracer
    Reputation
    1,960
View All

Find great deals from top-rated dealers

Search

Related Models For Sale

Used Chevrolet Tahoe
17 Great Deals out of 721 listings starting at $6,871
Used Jeep Grand Cherokee
102 Great Deals out of 4,766 listings starting at $1,938
Used Chevrolet Silverado 1500
106 Great Deals out of 10,264 listings starting at $3,655
Used Chevrolet Blazer
3 Great Deals out of 1,157 listings starting at $4,790
Used Ford Explorer
42 Great Deals out of 2,871 listings starting at $3,999
Used Chevrolet Impala
16 Great Deals out of 944 listings starting at $2,495
Used GMC Envoy
19 listings starting at $5,995
Used Chevrolet Equinox
65 Great Deals out of 5,522 listings starting at $1,800
Used Ford F-150
196 Great Deals out of 12,223 listings starting at $521
Used Dodge Durango
41 Great Deals out of 930 listings starting at $5,995
Used Chevrolet Avalanche
10 Great Deals out of 128 listings starting at $4,991

Used Cars for Sale

2009 Chevrolet Trailblazer For Sale
2 listings starting at $7,950
2008 Chevrolet Trailblazer For Sale
7 listings starting at $5,995

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use. Content will be removed if CarGurus becomes aware that it violates our policies.