Sensor problem or fuel pump


Asked by Jan 07, 2018 at 08:15 PM about the 1992 Oldsmobile Eighty-Eight Royale

Question type: Maintenance & Repair

I was on the highway going 70mph then my car
just drop to 50mph now it don't want to go pass 50
now can the mass air flow sensor cause that
problem or the fuel pump

9 Answers


see if you can get any codes , look for loose broken vacuum lines/hoses or if there's any noise at idle


No broken hose anywhere


My security light keeps coming on


Its like the car is not shifting into next gear I just change my trans two month ago


you did the tranny swap ? was it a new , rebuilt original or from a salvage yard ?


It was, from a friend of mimes car an it was working good... Do you think if I change out the transmission filter that could work or my fuel pump


you have to get any codes first ,


what model car did it come out of ?


It came out of a 1999 Buick Lena. And no I didn't get any codes I don't have an machine for that

Your Answer

Eighty-Eight Royale

Looking for a Used Eighty-Eight Royale in your area?

CarGurus has 2 nationwide Eighty-Eight Royale listings and the tools to find you a great deal.

Postal Code:

Oldsmobile Eighty-Eight Royale Experts

  • #1
    Michael Urbanski
  • #2
    John Saffrahn
  • #3
    Tom Demyan
View All

Related Models For Sale

Used Buick LeSabre
9 listings starting at $3,795
Used Lincoln Town Car
13 listings starting at $1,850
Used Buick Regal
214 listings starting at $8,995
Used Chevrolet Camaro
1,085 listings starting at $12,995
Used Ford F-150
551 Great Deals out of 10,128 listings starting at $3,490

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.