Throttle position sensor replaced, three days later the car does not go into reverse

Asked by Apr 11, 2017 at 08:34 PM about the 1994 Buick LeSabre

Question type: Maintenance & Repair

We had the local garage replace the Throttle position sensor. It has ran fine for three days. Now today when you put the car in reverse it will not back up. The tranny fluid is full and clean. As far as I can tell all of the vacuum hoses appear attached.  We will be taking it back to the garage.  It has about 135,000 miles on it. Any suggestions as to what may have happened?

No answers yet

Your Answer

Add photo

Related Questions

Search Buick LeSabre Questions

Buick LeSabre Experts

#1 Tom Demyan
Tom Demyan
Reputation 2,130
#2 John Saffrahn
John Saffrahn
Reputation 1,770
#3 Austin Gaboda
Austin Gaboda
Reputation 1,420
View All

Related Models For Sale

Used Buick Regal
10 Great Deals out of 382 listings starting at $9,555
Used Chevrolet Impala
58 Great Deals out of 982 listings starting at $799
Used Buick Century
18 listings
Used Toyota Camry
42 Great Deals out of 1,852 listings starting at $838
Used Honda Accord
117 Great Deals out of 1,243 listings starting at $1,495
Used Nissan Altima
74 Great Deals out of 1,200 listings starting at $2,500
Used Ford Taurus
32 Great Deals out of 303 listings starting at $4,988

Used Cars For Sale

2005 Buick LeSabre For Sale
3 listings starting at $2,500

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.