Despite new radiator and thermostat, my buick century is running near red line, Very hot.

Asked by Jul 29, 2017 at 06:23 PM about the 1997 Buick Century

Question type: Maintenance & Repair

I had a mechanic swap out the radiator again. (I had just changed it two months ago, but I think a leak developed in the new one.  Three weeks ago I drove it 50 miles with no trouble.  But on the way back I had to stop about five times to keep the motor from burning up.  I just changed the radiator cap today too.  But ... the shop that put on the new radiator tells me I should have also changed the thermostat again even though their test shows the stat is working.  I am guessing the water pump may have failed, or perhaps coolant is disappearing inside the motor somehow though my mechanical kin see no evidence of that in the oil/

No answers yet

Your Answer

Buick Century Experts

  • #1
    John Saffrahn
    Reputation
    970
  • #2
    Tom Demyan
    Reputation
    800
  • #3
    John Pate
    Reputation
    540
View All

Related Models For Sale

Used Buick Regal
5 Great Deals out of 301 listings starting at $6,995
Used Buick LeSabre
15 listings starting at $1,400
Used Chevrolet Impala
134 Great Deals out of 1,046 listings starting at $1,500
Used Honda Accord
84 Great Deals out of 1,059 listings starting at $1,200
Used Toyota Camry
65 Great Deals out of 1,963 listings starting at $750
Used Chevrolet Malibu
80 Great Deals out of 2,216 listings starting at $2,994
Used Honda Civic
297 Great Deals out of 3,485 listings starting at $995
Used Ford F-150
496 Great Deals out of 10,168 listings starting at $3,450
Used Nissan Maxima
23 Great Deals out of 364 listings starting at $3,990
Used Nissan Altima
74 Great Deals out of 1,358 listings starting at $2,500

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.