Sputtering/ Engine cutting off

Asked by Jun 21, 2018 at 02:46 PM about the 2004 Buick Century

Question type: Maintenance & Repair

I have been noticing recently that my car is becoming hard to start unless I
give it gas by pumping the pedal. Once running the car idles and runs good
until it has warmed up a bit. Once warmed up the car begins to idle roughly
and it will cut off after a period of time especially when I slow down and am
making a right hand turn. Do you have any idea what could be causing this
problem? It is an SFI 3100 motor

No Answers Yet

Your Answer:

Buick Century Experts

  • #1
    John Saffrahn
    Reputation
    1,050
  • #2
    Tom Demyan
    Reputation
    960
  • #3
    John Pate
    Reputation
    720
View All

Related Models For Sale

Used Buick LeSabre
3 listings
Used Buick LaCrosse
4 Great Deals out of 299 listings starting at $6,994
Used Buick Regal
4 Great Deals out of 140 listings starting at $6,988
Used Chevrolet Impala
23 Great Deals out of 868 listings starting at $2,894
Used Chevrolet Malibu
40 Great Deals out of 1,794 listings starting at $1,995
Used Honda Accord
38 Great Deals out of 1,652 listings starting at $3,490
Used Toyota Camry
36 Great Deals out of 2,122 listings starting at $2,450
Used Nissan Maxima
337 listings starting at $3,800
Used Honda Civic
123 Great Deals out of 4,669 listings starting at $1,655
Used Cadillac DeVille
13 listings

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.