No forward or reverse in my 1953 belair powerglide.

Asked by May 10, 2017 at 09:34 PM about the 1953 Chevrolet Bel Air

Question type: Maintenance & Repair

I was backing up my 1953 belair 2-speed powerglide out of the garage and I
mistakenly shifted it to early into drive at a very slow speed. I put it in park
and then tried to move it back in the garage but it doesn't go in forward or
reverse. Fluids are good, linkage is good. something must of broke inside.
Does anyone have a ideas? I don't want to pull the motor. Trans was rebuilt
3-years. 100 miles on it. Had just put the motor back in.

1 Answer

127,435

If it has been sitting that long it is highly probable that the linings on the discs inside the clutch drum has just went bye bye due to lack of fluid impregnation or you could have also snapped the main band, either way the tranny has to come back out and torn down to find out what actually happened.

Your Answer:

Chevrolet Bel Air Experts

  • #1
    WheelerDealer
    Reputation
    220
  • #2
    tenspeed
    Reputation
    190
  • #3
    COMETGUY61
    Reputation
    160
View All

Related Models For Sale

Used Chevrolet Corvette
26 Great Deals out of 839 listings starting at $12,900

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use. Content will be removed if CarGurus becomes aware that it violates our policies.