Fuel pump only getting 3 volts.

Asked by May 18, 2018 at 01:05 AM about the 1990 Chevrolet S-10

Question type: Maintenance & Repair

I've replaced fuel pump, tested it and it
works. Cleaned all grounds. Checked all
wires to and from fuel pump and relay no
issues.  replaced relay,replaced fuel
regulator, fuel filter, cap,rotor,plugs, blew all
fuel lines out. Cleaned out throttlebody got a
repair kit all new. The only way s10 will run is  
to run hot wire from battery whitch makes
fuel pump run constant. I'm starting to think
it's my Ecm? Can anybody help me figure my
problem out?

No Answers Yet

Your Answer:

Chevrolet S-10 Experts

  • #1
    Andrew Olsen
    Reputation
    2,810
  • #2
    John Saffrahn
    Reputation
    1,110
  • #3
    Trebor66
    Reputation
    1,090
View All

Related Models For Sale

Used Ford Ranger
9 Great Deals out of 294 listings starting at $2,995
Used GMC Sonoma
4 listings starting at $4,950
Used Ford F-150
132 Great Deals out of 11,223 listings starting at $369
Used Dodge Dakota
4 Great Deals out of 143 listings starting at $3,888
Used Chevrolet Blazer
14 listings
Used GMC Sierra 1500
87 Great Deals out of 11,141 listings starting at $3,880
Used Chevrolet Camaro
6 Great Deals out of 1,085 listings starting at $4,500
Used Ford Mustang
20 Great Deals out of 1,358 listings starting at $2,995

Used Cars For Sale

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.