I have a 95 S10 and when i try to start it i have the clutch pushed in and it clicks but my battery is good and i just replaced my starter.

Asked by Jan 28, 2016 at 10:19 AM about the 1995 Chevrolet S-10

Question type: Maintenance & Repair

1 Answer

69,655

Sounds like some bad connections or possibly bad battery cables.

Your Answer

Add photo

Related Questions

Search Chevrolet S-10 Questions

Chevrolet S-10 Experts

#1 Andrew Olsen
Andrew Olsen
Reputation 2,300
#2 John Saffrahn
John Saffrahn
Reputation 970
#3 Trebor66
Trebor66
Reputation 960
View All

Related Models For Sale

Used Ford Ranger
47 Great Deals out of 279 listings starting at $2,950
Used GMC Sonoma
5 listings starting at $3,995
Used Toyota Tacoma
16 Great Deals out of 766 listings starting at $4,950
Used Ford F-150
295 Great Deals out of 8,121 listings starting at $2,499
Used Dodge Dakota
17 Great Deals out of 151 listings starting at $1,995
Used GMC Sierra 1500
146 Great Deals out of 7,542 listings starting at $3,950
Used Chevrolet Blazer
16 listings starting at $1,789
Used Dodge Ram 1500
52 Great Deals out of 478 listings starting at $2,500
Used Chevrolet Camaro
984 listings starting at $13,999
Used Ford Mustang
1,334 listings starting at $5,980

Used Cars For Sale

2002 Chevrolet S-10 For Sale
1 listings starting at $1,195

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.