My car start but when I put in drive after it warm up it stalls

Asked by Jan 09, 2016 at 09:20 PM about the 1998 Oldsmobile Cutlass

Question type: Maintenance & Repair

I have a 1998 Oldsmobile cutlass and have a couple issues and need help.  Check engine light
was on and now it don't work, gas gauge stopped working and I noticed lights acting crazy?
What causes this as I noticed it when I seen a oil leak.  Also before that happened when my car
warms up temp gauge gets half way normal range it acts like it isn't getting fuel and sputters
and stall out I restart the car put it in gear and stalls again I have changed fuel filter and ignition  
placement sensor and nothing registers on a computer from auto zone or orilys please help

2 Answers


Try injector cleaner.. Gas gauge could be indication fuel pump going. Float messing up. With something that doesn't cause a spark hit the tank. Not hard enough to put a hole but get its attention. See if there is a change. Fuel pump my though.

My brother has a 1992 Oldsmobile Cutlas Supreme , he just got it, was having same problem, we disconnected the plug in connection at the transmission which disables over drive I think. His isn't quitting now, hopefully it keeps running. Ask someone about doing that.

Your Answer

Oldsmobile Cutlass Experts

  • #1
  • #2
  • #3
View All

Related Models For Sale

Used Chevrolet Monte Carlo
16 listings starting at $4,995
Used Chevrolet Camaro
1,058 listings starting at $12,995
Used Buick Regal
5 Great Deals out of 222 listings starting at $6,495
Used Ford Mustang
1,021 listings starting at $3,900
Used Pontiac Firebird
11 listings starting at $17,000
Used Chevrolet Malibu
70 Great Deals out of 1,823 listings starting at $2,495

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.