My car start but when I put in drive after it warm up it stalls

Asked by Jan 09, 2016 at 09:20 PM about the 1998 Oldsmobile Cutlass

Question type: Maintenance & Repair

I have a 1998 Oldsmobile cutlass and have a couple issues and need help.  Check engine light
was on and now it don't work, gas gauge stopped working and I noticed lights acting crazy?
What causes this as I noticed it when I seen a oil leak.  Also before that happened when my car
warms up temp gauge gets half way normal range it acts like it isn't getting fuel and sputters
and stall out I restart the car put it in gear and stalls again I have changed fuel filter and ignition  
placement sensor and nothing registers on a computer from auto zone or orilys please help
thanks

1 Answer

120

Try injector cleaner.. Gas gauge could be indication fuel pump going. Float messing up. With something that doesn't cause a spark hit the tank. Not hard enough to put a hole but get its attention. See if there is a change. Fuel pump my though.

Your Answer

Add photo

Related Questions

Search Oldsmobile Cutlass Questions

UK Questions

Are you a UK consumer? CarGurus now has a discussion forum in the UK.

Oldsmobile Cutlass Experts

#1 F_O_R
F_O_R
Reputation 140
#1 FordNut
FordNut
Reputation 140
#3 bluRAYwhale
bluRAYwhale
Reputation 90
View All

Related Models For Sale

Used Chevrolet Monte Carlo
14 listings starting at $6,941
Used Chevrolet Camaro
970 listings starting at $12,977
Used Ford Mustang
6 Great Deals out of 832 listings starting at $4,000
Used Buick Regal
8 Great Deals out of 264 listings starting at $3,600
Used Chevrolet Corvette
368 listings starting at $8,993
Used BMW 7 Series
102 listings starting at $7,500