I have a 2004 Olds Alero. While driving to work this morning, the engine started reving but no acceleration. I pulled over to the side of the road, put it in neutral and then park and then drive again, and again, the engine would rev but would not move forward. It will reverse but will not move forward. What could the problem be?

Asked by Jun 10, 2016 at 10:59 AM about the 2004 Oldsmobile Alero

Question type: Maintenance & Repair

1 Answer

294,005

Sounds transmission related. It's not engaging? A low fluid level sometimes causes this issue. Are you leaking fluid? Also could be an internal failure or solenoid issue. Best to have the pros check it out.

Your Answer:

Oldsmobile Alero Experts

  • #1
    sun4shine2006
    Reputation
    620
  • #2
    Chris Kelso
    Reputation
    260
  • #3
    Rowefast
    Reputation
    220
View All

Related Models For Sale

Used Pontiac Grand Am
31 listings
Used Pontiac G6
112 listings starting at $3,997
Used Toyota Corolla
108 Great Deals out of 4,195 listings starting at $2,100
Used Ford Focus
35 Great Deals out of 2,429 listings starting at $2,534
Used Chevrolet Impala
20 Great Deals out of 1,057 listings starting at $2,995
Used Nissan Altima
31 Great Deals out of 1,209 listings starting at $2,000
Used Honda Accord
26 Great Deals out of 1,618 listings starting at $3,495
Used Pontiac Grand Prix
43 listings starting at $4,495

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.