Loss of power

Asked by Jun 26, 2018 at 01:09 AM about the 1999 Mercury Sable

Question type: Maintenance & Repair

When I try to start I loose all power
nothing. Lights all work until I turn key on
then nothing works for about 15 minutes
then all over again. New starter, battery,
cables, relays tested fine, car ran fine
yesterday

No Answers Yet

Your Answer:

Mercury Sable Experts

  • #1
    JP1956
    Reputation
    890
  • #2
    Guy Outland
    Reputation
    440
  • #3
    tennisshoes
    Reputation
    400
View All

Related Models For Sale

Used Ford Taurus
7 Great Deals out of 306 listings starting at $5,990
Used Chevrolet Impala
23 Great Deals out of 926 listings starting at $2,400
Used Honda Civic
129 Great Deals out of 4,714 listings starting at $1,888
Used Buick LeSabre
8 listings
Used Toyota Corolla
78 Great Deals out of 4,247 listings starting at $3,450
Used Nissan Altima
39 Great Deals out of 1,324 listings starting at $1,995
Used Ford Explorer
29 Great Deals out of 1,652 listings starting at $2,995
Used Toyota Camry
31 Great Deals out of 1,929 listings starting at $1,750
Used Ford Mustang
50 Great Deals out of 1,531 listings starting at $2,900
Used Lincoln Town Car
12 listings starting at $6,995

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use. Content will be removed if CarGurus becomes aware that it violates our policies.