No power no crank no lights

Asked by Nov 04, 2017 at 03:12 PM about the 1999 GMC Sonoma

Question type: Maintenance & Repair

The battery terminal on my 99 gmc Sonoma broke
off. I replaced the terminal and when I went to
connect it to the battery I get nothing. Tested the
battery and it’s still good. The altinator is still good.
Used the there and power is coming off the battery
and the altinator.

1 Answer

132,075

Sounds like a bad battery cable, you did make sure the battery posts and terminal ends were shiny clean, none of that black corrosion.

Your Answer:

GMC Sonoma Experts

  • #1
    parkle
    Reputation
    860
  • #2
    Mike Bonnell
    Reputation
    520
  • #3
    James Mayfield
    Reputation
    330
View All

Related Models For Sale

Used Chevrolet S-10
5 listings
Used Ford Ranger
7 Great Deals out of 331 listings starting at $1,999
Used GMC Sierra 1500
91 Great Deals out of 9,238 listings starting at $3,999
Used Chevrolet Silverado 1500
90 Great Deals out of 9,481 listings starting at $3,500
Used Toyota Tacoma
43 Great Deals out of 1,657 listings starting at $5,450
Used Ford F-150
170 Great Deals out of 10,911 listings starting at $1,900
Used Dodge Dakota
4 Great Deals out of 133 listings starting at $4,295
Used Nissan Frontier
14 Great Deals out of 575 listings starting at $3,488
Used Dodge Ram 1500
14 Great Deals out of 450 listings starting at $3,900
Used Chevrolet Blazer
9 listings starting at $2,500
Used GMC Jimmy
14 listings
Used Chevrolet Tahoe
16 Great Deals out of 1,122 listings starting at $4,999

Used Cars for Sale

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use. Content will be removed if CarGurus becomes aware that it violates our policies.