Fuel not getting fuel to the fuel filter

Asked by Jan 23, 2018 at 03:34 PM about the 1981 Chevrolet C/K 20

Question type: Maintenance & Repair

I got an 81 Chevy Scottsdale K20 four-
wheel drive long bed to fuel filter I
replace the fuel pump and filled it with
gas still no fuel what could it be?

3 Answers

201,005

Electric or mechanical fuel pump?

3 people found this helpful.
163,645

Collapsed fuel line somewhere from the tank to the pump, totally rusted away fuel line so no suction getting to the fuel tank, plugged fuel inlet sock inside the fuel tank. I ace seen a lot of these rust the complete pickup tube so bad that anything short of an overfilled fuel tank will keep it from getting any fuel at all.

2 people found this helpful.
40

I have a 79 Silverado K20 that I was driving and then died on the side of the road. Tried starting it but won't start just kept cranking until it ate my battery. Prior to getting stuck it was really on empty E line so I gassed it with $20.I drove it for about 8 miles then that's when I got stuck. Also I looked at the fuel filter next to the carb and it seems like there's no gas going thru but you can see the movement on filter sucking but nothing at all. Pls help and sorry English is my second language.

4 people found this helpful.

Your Answer:

C/K 20

Looking for a Used C/K 20 in your area?

CarGurus has thousands of nationwide listings and the tools to find you a great deal.

Postal Code:

Shortcuts

Chevrolet C/K 20 Experts

  • #1
    F_O_R
    Reputation
    160
  • #2
    kayzen
    Reputation
    80
  • #3
    Kari Goen
    Reputation
    60
View All

Related Models For Sale

Used Chevrolet Camaro
9 Great Deals out of 1,310 listings starting at $5,500
Used Chevrolet Blazer
760 listings starting at $2,100
Used Chevrolet S-10
2 listings
Used Ford F-250
6 listings

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use. Content will be removed if CarGurus becomes aware that it violates our policies.