79 k5 blazer. brand new 350 engine. lacking power while accelerating.

Asked by May 28, 2019 at 08:19 PM about the 1979 Chevrolet C/K 10

Question type: Car Customization

not getting enough power between 5-40 mph before kicking (with a significant
jolt) into 2nd.   I just put this new engine in, bought from chevy dealer, after
blowing out the old one.  had to drive it immediately from utah to canada after
the work was done.  ive checked all the fluids several times since the long
drive and added more transmission fluid.  the pickup on initial acceleration is
lacking and obviously not working properly from the sound and feeling.  any
tips would be greatly appreciated

No Answers Yet

Your Answer:

Chevrolet C/K 10 Experts

  • #1
    CaptPKelly
    Reputation
    2,570
  • #2
    F_O_R
    Reputation
    590
  • #3
    John Carson
    Reputation
    530
View All

Find great deals from top-rated dealersTM

Search

Related Models For Sale

Used Chevrolet Camaro
23 Great Deals out of 1,193 listings starting at $9,931
Used Ford F-150
126 Great Deals out of 12,913 listings starting at $1,000
Used Chevrolet Blazer
1,309 listings starting at $36,546
Used Ford F-100
6 listings
Used Chevrolet Corvette
17 Great Deals out of 896 listings starting at $9,880
Used Ford Mustang
63 Great Deals out of 1,926 listings starting at $3,900

Used Cars for Sale

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use. Content will be removed if CarGurus becomes aware that it violates our policies.