Electrical or starter or what???

Asked by Mar 16, 2016 at 01:29 PM about the 1999 Chrysler 300M

Question type: Maintenance & Repair

I tried to start my car this morning and when I
turned the ignition I lost all powe.. no clicking
noise at all. No power what so ever! Key fob
doesn't even work! 1 hour later key fob works,
interior lights work, ignition dings when key is
inserted... however I turn the key and lose all
power! No key fob, no lights, no clicking! Just
complete loss of power! Any suggestions?

3 Answers

98,445

Sounds like dirty battery cables, both the posts and the terminal ends have to be shiny clean, none for that black corrosion. Or the battery is on it's last legs.

1 of 1 people found this helpful.

Dirty terminals and cables!! Thanks fired right up after I cleaned them up!

98,445

Great. Happy Motoring

Your Answer

300M

Looking for a Used 300M in your area?

CarGurus has 7 nationwide 300M listings and the tools to find you a great deal.

Postal Code:

Chrysler 300M Experts

  • #1
    Jearod Leet
    Reputation
    440
  • #2
    Felix Melendez
    Reputation
    410
  • #3
    aztec626bf
    Reputation
    400
View All

Related Models For Sale

Used Chevrolet Camaro
796 listings starting at $10,000
Used Ford Mustang
9 Great Deals out of 1,191 listings starting at $2,995
Used Honda Accord
62 Great Deals out of 1,114 listings starting at $748
Used Jeep Grand Cherokee
108 Great Deals out of 2,738 listings starting at $1,871
Used Chevrolet Impala
61 Great Deals out of 938 listings starting at $1,900
Used Dodge Durango
62 Great Deals out of 1,013 listings starting at $2,998
Used Nissan Maxima
29 Great Deals out of 324 listings starting at $3,976
Used Ford F-150
456 Great Deals out of 9,064 listings starting at $922

Used Cars For Sale

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.