i have a 2003 chrysler voyager, at first it was sputtering and dying while driving, we replaced fuel pump didnt do it again for a while then started again autozone codes said crank shaft sensor and ca

Asked by Dec 06, 2015 at 10:21 AM about the 2003 Chrysler Voyager

Question type: General

i have a 2003 chrysler voyager, at first it was sputtering and dying while
driving, we replaced fuel pump didnt do it again for a while then started again
autozone codes said crank shaft sensor and cam shaft sensor replaced those
now wont start jumped battery still wont start. ready to junk it help please has
new wires, plugs and oil change

1 Answer

24,415

Did a shop replace the cam and crank sensors? Those have to go back in precisely the same position they were in, otherwise timing will be off.

1 of 1 people found this helpful.

Your Answer

Add photo

Related Questions

Shortcuts

Search Chrysler Voyager Questions

Chrysler Voyager Experts

#1 darrellshirley
darrellshirley
Reputation 320
#2 Ronald Dake
Ronald Dake
Reputation 260
#3 lightGear
lightGear
Reputation 160
View All

Related Models For Sale

Used Chrysler Town & Country
60 Great Deals out of 923 listings starting at $5,850
Used Dodge Caravan
97 listings
Used Chrysler Pacifica
6 Great Deals out of 1,391 listings starting at $4,888
Used Honda Odyssey
15 Great Deals out of 745 listings starting at $3,450
Used Dodge Grand Caravan
182 Great Deals out of 11,563 listings starting at $710
Used Toyota Sienna
7 Great Deals out of 965 listings starting at $2,995
Used Kia Sedona
420 listings starting at $3,995

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.