2003 Ford windstar (weak acceleration, rough idle, hard time getting past 45mph)

Asked by Nov 20, 2019 at 09:08 PM about the 2003 Ford Windstar Cargo

Question type: Maintenance & Repair

Hello everyone, so I have a 2003 Ford windstar with roughly 195k and it
started losing power, it has a pretty rough idle, weak acceleration, has a hard
time getting past 40-50 mph, feels like it wants to die but it hasn't so I've
been avoiding driving it but I need it running asap. I was told to replace spark
plugs, cables and coil pack. Got those replaced and it seemed to help the
rough idle but by the time I got back back home it started to lose a lot of
power and the idle got rough again! I'm going to get it hooked up to a code
machine hopefully this weekend. Any suggestions or ideas what it might be?
Someone said it might be bad alternator, fuel pump, fuel filter and that's all
I've heard.

1 Answer

87,415

Most likely an exhaust restriction, like a clogged catalytic converter. Might be a fuel problem. Failing pump, clogged filter, dirty injectors, the list goes on. If you have a warning light, there are codes associated. go to an auto parts store to get them read.

1 people found this helpful.

Your Answer:

Shortcuts

CarGurus Experts

  • #1
    lalvear1217
    Reputation
    70
  • #1
    COMETGUY61
    Reputation
    70
  • #3
    Brenda Chambers
    Reputation
    50
View All

Find great deals from top-rated dealers

Search

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use. Content will be removed if CarGurus becomes aware that it violates our policies.