Car won't run right

30

Asked by May 29, 2016 at 02:17 PM about the 1975 Ford Ranchero

Question type: Maintenance & Repair

My 1975 Ford ranchero had a rusty fuel
tank. I replaced the tank and fuel filter. It
starts right up and idles fine. Runs good for
a little while when driving then bogs and
quits. It seems like a dirty fuel line or the
sending unit. Any ideas?

2 Answers

104,385

Most likely you have crud in the fuel pump, I would replace the pump, and replace the fuel filter at the carb. You might consider putting an inline clear gas filter just before the pump in case there is rust breaking away in the stock fuel lines, it will catch it before it damages the new fuel pump. HTH

116,045

I agree. If that don't help then I would also check the needle valve on the carb. Trash could be restricting flow.

Your Answer

Shortcuts

Ford Ranchero Experts

  • #1
    MrBlueOval
    Reputation
    190
  • #2
    dandyoun
    Reputation
    150
  • #3
    Michael Tutty
    Reputation
    120
View All

Related Models For Sale

Used Ford F-150
656 Great Deals out of 13,620 listings starting at $3,000
Used Ford Mustang
14 Great Deals out of 1,156 listings starting at $4,500
Used Ford F-100
2 listings
Used Chevrolet Camaro
917 listings starting at $12,000
Used Ford Thunderbird
24 listings starting at $11,777
Used Ford Bronco
2 listings

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.