opel corsa c gsi 2005 model gramma

Asked by Dec 29, 2015 at 04:47 AM about the 2005 Opel Corsa

Question type: Maintenance & Repair

it broke camshaft at 167000km the i had the pistol rings changed and soon
after we put the engine together and start it i notice the service light on(car
with a spanner) but running fine then i started getting rich mixture and sofar i
have changed the cam sensor, coil pack since plug number 3 keeps oiling up
but stil its not changing please tell me what could it be please help

1 Answer

5

Egnition off. Press odo meter reset button in and hold, turn egnition on but do not start. Keep like that for max 30 seconds and let go. See if it is reset, if the problem persist the light will come back on. Then switch off the car. Press brake and excilirator down, turn on egnition but do not start. Count the flashes of the service light. It will flash and pause, that is the first number, it wil flash again and pause until there is a long pause which is the end of the code. 1flash is 1, 2flash is 2, al the way to 9. 10 flashes is 0. Take the code that you get and google it for your fault

Your Answer

Shortcuts

Opel Corsa Experts

  • #1
    Pd Mupatsi
    Reputation
    1,080
  • #2
    AntSavo76
    Reputation
    560
  • #3
    Esme123
    Reputation
    450
View All

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.