Opel Corsa 1.4 Utility, Engine low revs and cuts out when driving slowley

50

Asked by Gazzy Jan 07, 2016 at 08:09 AM about the 1999 Opel Corsa

Question type: Maintenance & Repair

I'm  having problems with my Opel Corsa 1.4 Utility having intermittent engine running problems-(especially when outside temperature is high). When car starts and warms up and I drive away and the engine starts hunting and drops to low revs when car slows down(mainly when slowing down in traffic, stop streets or red robots. In many instances the engine cuts out and will not start for a while. Sent the vehicle to Opel agents, they connected to diagnostics but all showed ok,even whilst the car wouldn't start. When driving at higher speeds 80 to 100km the vehicle runs ok in most instances but has recently occasionally started spluttering and appears as if the  the car is running on 3-cylinders & then comes right and runs normal-(which is quite hair-raising especially when over taking an another vehicle).

5 Answers

50

I would say it the crank gear. There is a keyway on the crank shafts the wears out which causes the gear to shift out of place. It would run fine at high speeds and gears but should be retarded on take off and slow speeds.

5 people found this helpful.
50

Hi Marcus, Thanks for yr suggestion. I eventually found when the engine got to operating temperature it started to idle badly. After checking spark we found 2-leads not having spark but when the engine was switched off & left to cool down, the spark returned to those leads. We replaced the coil & solved that problem, however the issue with the engine hunting continues when slowing down-when the brake is applied on hot days only. I have been advised that the brake booster vucuum seal may be faulty b/cause when the outside temp is hot the engine runs leaner but if there is a leak in the booster seal it draws more putting more strain on the engine to operate thus in a sense starving the engine. When I have come to a halt the revs pick up to normal until the next time I apply the brakes. On cool days it does not display those symptoms. So I suppose I'll change the seal & see what transpires.

5 people found this helpful.
230

I also having a problem with my Opel corsa utility 1.4 2006 model At first we found out the crank shaft has warn out n I changed the crank but now it will startvto show the engine lite while iam driving and cuts out and at some point it just stops We tried to check if there was fault in the engine and we found nothing it now started some weird idling while iam driving like I put my refs to the last point What can be the problem there

23 people found this helpful.
10

Hi guys, Gazzy is right. I think we all have the same problem. I currently have the exact same problem on my Opel corsa 1998 van 1.4i, it starts and drivers fine when cold then hunts when it's hot. Over fueling constantly and also cuts off when I'm in a stationary position. My brake booster is sucking in air terribly and my coil needed replacing, also changing your sensors would help (throttle body etc) do not ignore your brake booster, that is your biggest problem! Local mechanic was charging R800 for a new seal that costs R199 and yet a new complete booster costed R1000, I replaced the whole unit myself instead. Been a beauty ever since, no regrets

1 people found this helpful.
20

Wat is it with Opels Good morning to All I have a Opel corsa 1.3 98 model the Ne engine. I have a similar problem with my car over fueling no revs when I start it. In the morning it would start easy but still jerk and in the afternoon when I leaf for home it takes a lot of cranking before it starts and during starts it will back fire. so I started with service and when that did not help replaced all the sensors then the T-bel (I Have Double checked my timing and is Very sure that it is right) Replaced crank gear, crank pickup, coil, plug leads tested and cleaned my injectors and intake butterfly. replaced the fuel pump relay and fuel pump.After all that it ran sort of ok for a few day's and last night it acted up again checked my plugs an sow it's black as night replaced them wit new ones, so after that it starts but does not rev up. After a few min running the exhaust manifold become extremely red so I switched it off and towed it home. I have a OBD 2 Diagnostic tester but can't seem to get it to connect to the Car's computer,because the check engine light is on. This exercise is starting to cost me a lot. Any Thoughts on where else I can search for the problem. There is no holes in the exhaust and the car is defiantly over fueling. I also get some oil in the intake from the tappet cover and think that might also be part of the problem. I also found that the Fuel relay Became extremely hot some times. So I have checked the earth wires on the engine but all is ok there. Hope this Is enough info For someone that can Help Please it's not my best car It's my Only. Thanks so far have a nice day All.

Your Answer:

Corsa

Looking for a Used Corsa in your area?

CarGurus has thousands of nationwide listings and the tools to find you a great deal.

Postal Code:

Shortcuts

Opel Corsa Experts

  • #1
    Pardon Mupatsi
    Reputation
    1,980
  • #2
    Clifford Netshilonwe
    Reputation
    1,750
  • #3
    Rowefast
    Reputation
    1,190
View All

Find great deals from top-rated dealers

Search

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use. Content will be removed if CarGurus becomes aware that it violates our policies.