Turn Signal / Running Light Issue

Asked by Jul 12, 2018 at 01:39 PM about the 1963 Ford Galaxie

Question type: Maintenance & Repair

Here's a diagnosis breakdown ...
With lights off, the driver's side signal flashes normally with normal
brightness.
Passenger side blinks, but is very week.

With just parking lights on, driver's side is dim, passenger side bright.  

With headlights on, driver side blinks normally, passenger side is barely
blinking.

I've checked and replaced the bulbs, cleaned the sockets, checked the
wiring.  I can't seem to find a problem or have any idea where else to check.

Nothing is affecting the rear signals.

No Answers Yet

Your Answer:

Shortcuts

Ford Galaxie Experts

  • #1
    MrBlueOval
    Reputation
    600
  • #2
    tennisshoes
    Reputation
    180
  • #3
    F_O_R
    Reputation
    150
View All

Related Models For Sale

Used Ford Mustang
62 Great Deals out of 1,554 listings starting at $2,900
Used Chevrolet Impala
24 Great Deals out of 931 listings starting at $2,400
Used Ford Fairlane
1 listing
Used Ford Thunderbird
22 listings starting at $11,900
Used Chevrolet Corvette
21 Great Deals out of 801 listings starting at $12,957
Used Ford F-100
6 listings

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use. Content will be removed if CarGurus becomes aware that it violates our policies.